Author Topic: I can't get WS Add-In to stay "registered"  (Read 8040 times)

Morris

  • Full Member
  • ***
  • Posts: 11
  • I love YaBB 1G - SP1!
I can't get WS Add-In to stay "registered"
« on: December 10, 2002, 05:34:57 AM »
I've installed the WS Add-In and it's working just fine, except: when I follow Mike's instructions for "how to register", my name and registration number appear in the "About" dialog box for as long as the program stays running ... but when I close down Word then re-open it, my name and number have disappeared on the WS Add-In screen, and I come up again as "unregistered". I'd appreciate help from anybody as to what I need to do so I register and stay registered! Thanks in advance.
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: I can't get WS Add-In to stay "registered"
« Reply #1 on: December 10, 2002, 08:22:10 AM »
Hi Morris,

Have a look at the FAQ about this type of problem at:
? ?http://www.wordstar.org/wsword/pages/faq.htm#FAQ61.

There are a couple of potential problems which relate to how Word accesses the Windows registry: Firstly, if you've installed the program in other than the STARTUP folder Word has problems with reading the registration details - or with setting them in the first place! Word is also iffy in running startup routines in add-ins, and one of these is needed to read your details from the registry. I've added the recommended workarounds for the second problem, there isn't one for the first.

Check the registry actually contains your details during and after running Word.

I hope this helps

Regards
Mike
« Last Edit: January 01, 1970, 04:00:12 AM by -1 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

Morris

  • Full Member
  • ***
  • Posts: 11
  • I love YaBB 1G - SP1!
Re: I can't get WS Add-In to stay "registered"
« Reply #2 on: December 16, 2002, 04:35:21 PM »
Dear Mike,

Thanks for  your reply. Thanks also for not replying with, "If in doubt, read the instructions"! I thought I'd combed thro' the FAQ on this, but clearly I missed it.

Anyway, I tested out your suggestions, and the Add-In is still not staying registered. I do run it in the way you recommend, i.e. by having copied Wordstar.dot to the Office Startup folder.

Not being too confident with Reg Edit, I first downloaded the patch you mentioned, and added my details in double quotes as you suggested. However, when I double-clicked the icon, I got a fault message that said:

"Cannot import ... the specified file is not a Registry script. You can import only Registry files".

So then I did go into Reg Edit, and found the point in it that you mentioned. When I got to this point, I saw in the right-hand pane that the number at "SN" was accurate. However, when I looked in the right-hand pane for "Name" to fill in my name, I could not see the heading "Name" - instead, there was the word "Default". I tried filling in "I. Stewart" (my name!) in the blank beside "Default", in double quotes, and saved the whole thing back to the Registry. But, no go.

I don't want to mess with Reg Edit, so I didn't try deleting the word "Default" that appeared where "Name" should have been. Do you, please, have any further suggestions? This is no problem to me as regards how well the Add-In is working (which it is), but I thought you might like to know about Word's continuing unwillingness to let me register!

With thanks,

Ian Stewart

(aka "Morris")
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: I can't get WS Add-In to stay "registered"
« Reply #3 on: December 20, 2002, 02:42:47 AM »
Hi Morris,

OK, I understand the unwillingness to mess with the registry. The error you saw was, I think, due to differences in the registry editer format with different versions of Windows.

Can I ask you to go into regedit again. Find the WordStar Emulator data again and this time, select the menu options Registry > Export. The menu option may be slightly different, but should be obvious. You'll have the option of exporting the "selected branch", which is the one you want. Choose a filename and save it. Find the saved file and you can either edit it in NotePad to add your details and then import it again, or change the file extension from .reg to .txt and email it to me and I'll make you a new version of the patch file that wouldn't import.

If you do this can you also let me know which version of Windows you're running, and the exact menu options for the registry export so I can add this to the FAQ.

Regards
Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: I can't get WS Add-In to stay "registered"
« Reply #4 on: December 22, 2002, 02:35:47 AM »
Having received a registry export from Morris' computer it was obvious where the problem lay. The export showed something like this:

Code: [Select]
REGEDIT4

[HKEY_CURRENT_USER\Software\Petrie\WordSTAR\1.0\UserInfo]
"SN"="12385678"
@="F Bloggs"

The error being that Word wasn't writing the key called "Name" but had placed an at-sign (@) in its place.

The download registry import file in the FAQ http://www.wordstar.org/wsword/pages/faq.htm#FAQ61 isn't suitable for Windows 98 so Morris couldn't use that - it's only the REGEDIT4 bit at the start of the file that's wrong for Windows 98, so I'll post another version and update the FAQ as well.

With the @ changed to Name all is well.

Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: I can't get WS Add-In to stay "registered"
« Reply #5 on: December 26, 2002, 02:40:22 AM »
The FAQ article http://www.wordstar.org/wsword/pages/faq.htm#FAQ61 has now been updated to cover missing/incorrectly saved names and key values.

I have also added a downloadable registry pach file for Windows 98 to go along with the Windows 2000/XP version that was already available. Download links for these are in the FAQ article above.

Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups