Author Topic: Wordstar 4 inside MSDOS not opening a new document after Linux co-installation  (Read 5008 times)

sukanth

  • New Member
  • *
  • Posts: 1
I am one of the fossilised  oldies who still cling on to - "Old is GOLD!" - Wordstar 4 for DOS shying away from MS word etc., I have worked with it for 15 years - on a machine running only MSDOS v.6.2; I have not been able to use it comfortably within MS WINDOWS XP on my Win machines- that was not a big handicap anyway.

All was well with DOS sitting in my 40 GB HDD and using only an 8 GB partition )minimum allowed for DOS) leaving the other 32 GB of HDD idle and inaccessible to DOS; also DOS allowed only 1.44 MB FDDs and not my USB pendrive for data transfer between my DOS machine and my Windows PCs - a real handicap!

So, I ambitiously repartitioned the 40 GB HDD on my DOS machine without disturbing my DOS partition, and installed LINUX Redhat v.7.0 in the other 32 GB on my HDD - DOS and Linux seemed to live happily together - until I tried to create a new WS document inside WS4as usual - WS4 simply said "Cannot create a new file - cannot create temporary file - your boot disk may be write-protected blah blah blah"! WS4Dos did all the other Document open, save, print etc., as usual! I devised a workaround - instead of trying to create a new file, I opened an existing WS4 document within WS4 and edited it suitably to get the "new" document and was able to save it, reopen it, edit it, print it etc., But this seemed to be a pathetic subtitute for opening a new WS4 document right royally!

I went into my boot partition C:\\ and deleted almost all files in its root leaving only the directories and a few essential root files like autoexec, config etc., That has not helped. What to do now? I tried to work with WS4 within Win XP - but the WS window allowed by XP is very small and dimly lit and not full screen and WS inside XP closes down with the least provocation of attempting filesave etc.,

All this only after I installed Linux in the 32 MB part of my HDD.

Can anyone please help me to open new WS4 documents inside WS4 in my DOS machine right royally again as I used to do before installing Linux to co-exist with MSDOS.

Zillion Thanx!


Admin Edit: Tidied line breaks and added blank lines
« Last Edit: October 10, 2007, 09:34:14 AM by Forum Admin »

PGAGA

  • Advanced Member
  • *****
  • Posts: 118
  • I love YaBB 1G - SP1!
Wednesday, October 10, 2007

Interesting, WS and most DOS programs have problems with partitions over 2 GIG.  The last system I had with a DOS boot, the drives combined were under 1 GIG.

The error message you state will also occur if temporary files exist with the same name as the new file you are trying to open.  Check for such artifacts.

Phil