Author Topic: no cursor  (Read 7481 times)

anggoro

  • New Member
  • *
  • Posts: 2
no cursor
« on: April 24, 2006, 12:24:43 PM »
hi,
i installed dosemu+freedos+wordstar smoothly. but, i have trouble with cursor. The cursor is still at the currect position which belong to freedos. So, i can type sentences but i don't know where the cursor is. anybody know?

ang 

deedee

  • Sr. Member
  • ****
  • Posts: 89
  • I love WordStar!
    • WordStar Users Group
Re: no cursor
« Reply #1 on: April 24, 2006, 08:39:46 PM »
I assume you're not seeing the cursor because you access dosemu and WordStar via a console or terminal. When one accesses dosemu via xdosemu and opens it in a window in KDE or Gnome or whatever desktop manager, the system appears to get it correct -- the mouse, keyboard, the character sets, what each keystroke does -- all get set the way they are in the desktop manager. When accessing dosemu and WordStar via a console or terminal, the user may need to configure one or more of these things.

You need to configure your mouse. Find dosemu.conf -- its location varies depending on how you installed dosemu -- systemwide for multiple users, from rpm or apt for single user, or from binaries for single user. If you have man pages for dosemu, check them out. They usually give the locations for most of the configurable files. If you don't have a man page (which you might not if you installed from binaries for a single user), your dosemu.conf should be located somewhere in $HOME/dosemu.

Dosemu.conf gives all the default information. It is commented out. You only need to change those things you don't want to be the default. Look in the section on the mouse. How the mouse is configured will show there. Someone on the WordStar Users Group mailing list suggested a tip which can be very helpful if you end up needing to experiment with various settings before you get it the way you want. Make a copy of dosemu.conf so you don't lose the information on what the default settings are. I generally just give it a new name like dosemu_old.conf. Then, create a new blank dosemu.conf and only add your changes for the mouse. Dosemu will keep everything the default except what you change and you will be able to easily see your nondefault settings.

Since I don't really know anything about your mouse or your system, I can't really give you more information on what to try at this point.

deedee
WordStar Users Group: http://www.wordstar2.com
WordStar Users Group Mailing Lists: http://wordstar2.com/mailman/listinfo
Reg. Linux User #327485

anggoro

  • New Member
  • *
  • Posts: 2
Re: no cursor
« Reply #2 on: April 25, 2006, 10:33:33 AM »
thanks, you're right. there's cursor in X mode. I use Debian sarge for my daily life. I've tried Dosbox, too. I think I prefer Dosbox than Xdosemu. What a wonderful Wordstar