Author Topic: WS 2 for Windows and Win XP  (Read 5805 times)

Matt_B

  • Member
  • **
  • Posts: 8
  • I love YaBB 1G - SP1!
WS 2 for Windows and Win XP
« on: June 07, 2005, 01:27:41 AM »
Been using WS for over 20 years and had WS 2 for Windows working just perfectly on my PC with Win2K OS.  But when I upgraded to a hot laptop with WinXP everything seemed to be fine until I noticed that a half dozen or so unrelated fonts disappeared from the lineup.  I still have scads of fonts but miss the ones that I was using in some important  templates.  The fonts are still on the computer but WS just doesn't recognize all of them.

Is there any suggestion how to get WS to see all the fonts that are installed.

Thanks

Matt Bracewell

deedee

  • Sr. Member
  • ****
  • Posts: 89
  • I love WordStar!
    • WordStar Users Group
Re:WS 2 for Windows and Win XP
« Reply #1 on: June 07, 2005, 01:41:33 AM »
Hi Matt,

There are a number of issues when using WSWin2 on an XP, including the font issue you noticed. Try viewing your fonts from the bottom up, instead of from the top down. For some reason, it will show all the fonts that way. Remember, however, that WSWin2 can only handle 250 font families. If your XP system has more than that installed, WSWin2 will not show them all.

Other issues have to do with creating bookmarks and macros in WSWin2. You can use any that were already created on an earlier system. However, people have found that they couldn't create any new ones in WSWin2 on an XP system.

deedee
WordStar Users Group: http://www.wordstar2.com
WordStar Users Group Mailing Lists: http://wordstar2.com/mailman/listinfo
Reg. Linux User #327485

Matt_B

  • Member
  • **
  • Posts: 8
  • I love YaBB 1G - SP1!
Re:WS 2 for Windows and Win XP
« Reply #2 on: June 07, 2005, 04:40:51 AM »
Thanks so much for your reply.  It turned out that I had a few hundred too many fonts.  I moved a ton of them to an external drive and PRESTO, Wordstar could read all the remaining fonts including the MISSING FONTS.

I am so grateful for your help.

Matt Bracewell

Matt_B

  • Member
  • **
  • Posts: 8
  • I love YaBB 1G - SP1!
Re: WS 2 for Windows and Win XP
« Reply #3 on: April 07, 2006, 01:27:21 AM »
Been using WSWIN 2.0 forever and for the past 18 months on a Toshiba laptop with WinXP without any problems.  Until yesterday.  Now I cannot open Wordstar and clicking WSD documents does nothing.  All other programs are runnng OK.  I have scanned my disk for viruses without finding anything (I use Panda), have run AdAware and Spybot and found nothing.

Any suggestions would be deeply appreciated.

Matt Bracewell

PGAGA

  • Advanced Member
  • *****
  • Posts: 118
  • I love YaBB 1G - SP1!
Re: WS 2 for Windows and Win XP
« Reply #4 on: April 07, 2006, 06:16:23 PM »
Friday, April 07, 2006

Hi Matt!

Been using WSWIN 2.0 forever and for the past 18 months on a Toshiba laptop with WinXP without any problems.  Until yesterday.  Now I cannot open Wordstar and clicking WSD documents does nothing.  All other programs are runnng OK.  I have scanned my disk for viruses without finding anything (I use Panda), have run AdAware and Spybot and found nothing.

This could be a number of things--most likely it is due to the number of fonts on your system.  WSWin on XP starts balking when the number starts climbing abnove over 150-170.  The file format no longer has the buffering space for creation of files.  Sometimes changing the fontmap setting in WSW.ini will get around the problem.

If it is not the number of fonts, then it means that corruption exists in one of the INI files.  Backup then delete from c:\windows WSW.INI, WSWFLT.INI, WSWIN.CFG, WSWSET.INI.  Then try running WSWin which should recreate the files.

Phil