Author Topic: WsWin 2.0 ?e-mail  (Read 13257 times)

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
WsWin 2.0 ?e-mail
« on: March 18, 2003, 07:50:39 AM »
I appreciate the ability to be part of the discussion group. I have been a WS user for 15 years. I own copies of Word 7 &  WPerfect 7 and work with Word 2000; but,  still use my WSWIN 2.0 for practically every wordprocessor or newsletter project.

I recently upgraded my computer system and moved up to Windows XP ver 2.1+ and reloaded my WSWIN from my original six disks, upgraded the ini and filter files and everything works great! However, I can't e-mail even after installing The mapi.dll file in the Windows system folder. Do you have any advice for this.  Thank You.
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: WsWin 2.0 ?e-mail
« Reply #1 on: March 18, 2003, 08:37:15 PM »
Hi,

Glad to have you on board!

I never used WSWin for email, but gave it a quick try today for the first time. After starting WSWin I ran the mailmapi.wmc macro, I had to confirm my messaging profile (due to the way I have Outlook installed) and then Outlook opened a blank message with the WSWin document as an attachment. I am using Windows XP with Outlook 2002. I have not copied any files anywhere to do this.

Perhaps my quick test isn't representative of what you're doing, but that method worked here.

Cheers
Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #2 on: March 19, 2003, 06:58:56 AM »
Mike: Thank you for the reply. However, I don't seem to be able to match your results. The way you described it, it's very similat to how it used to work with Windows Messanger when I was using Windows 95.  As it is now, it doesn't matter wheather I use the mail command on the file menu or run the mailmapi macro I get a message flag that it can't find mapi.dll file. I even changed the win.ini file for mapi from 1 to 0 and it did the same thing; so, i changed it back. I don't know if there is a restrictive difference between Outlook 2002 that you use and Outlook Express 6.028 that is on my machine. Any ideas?
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

deedee

  • Sr. Member
  • ****
  • Posts: 89
  • I love WordStar!
    • WordStar Users Group
Re: WsWin 2.0  e-mail
« Reply #3 on: March 19, 2003, 11:28:22 AM »
On my system, win98se, there is no mapi.dll. However, there is a mapi32.dll in the c:\windows\system folder. Mike, do you have mapi.dll or mapi32.dll or both? And just where is it?

Just trying to be sure that both of you are talking about the same files.

deedee
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
WordStar Users Group: http://www.wordstar2.com
WordStar Users Group Mailing Lists: http://wordstar2.com/mailman/listinfo
Reg. Linux User #327485

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: WsWin 2.0 ?e-mail
« Reply #4 on: March 19, 2003, 01:15:11 PM »
I actually have both a mapi.dll and a mapi32.dll. I don't have any mapi statements in wswin.ini.


Cheers
Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #5 on: March 20, 2003, 10:00:16 AM »
Perhaps I misled you,  Windows XP installed with only a-file sfmapi32.dll that was in the Windows\system32 folder. There was no mapi.dll or mapi32.dll files. Also, none of the files were in the Windows\system folder - which I thought was for 16 bit program compatibility. This may be incorrect, I'm not sure. Anyway, I assumed that since WSWIN was a 16 bit program I needed the 16 bit mapi.dll file in the Windows\system folder.  So, I loaded it to there. The set mapi command is in win.ini and loads at startup. The error message I keep getting is "can't find mapi.dll file". I'm going to move the file to the Windows\system32 folder, along with mapi32.dll and see what happens.  I'll inform you of the results. Any thoughts are welcome. Thanks
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: WsWin 2.0 ?e-mail
« Reply #6 on: March 21, 2003, 01:22:18 AM »
Hi,

OK, in my XP Home win.ini file I have the following mail settings:
Code: [Select]
[Mail]
MAPI=1
CMC=1
CMCDLLNAME=mapi.dll
CMCDLLNAME32=mapi32.dll
MAPIX=1
MAPIXVER=1.0.0.1
OLEMessaging=1

In WINDOWS\System32 I have:
  • MAPI.DLL
  • mapi32.dll
  • mapistub.dll
I have no other MAPI programs (If you have XP Pro it will be WINNT\System32)
I don't know what installed each version, or if they all came with Windows XP.

Cheers
Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

PGAGA

  • Advanced Member
  • *****
  • Posts: 118
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #7 on: March 22, 2003, 02:42:50 AM »
Friday 21 March 2003

For what it's worth, to get my MailAs macro (send an email written in WSWin or attach an open document in another format) to work properly under WinME I had to add a section at the beginning of the macro  to make sure Outlook was running.  If Outlook was not open, then the macro would fail.

Sorry can't make more of a statement since the WinME system is in Kentville and I am in Brooklyn.

Phil
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #8 on: April 18, 2003, 10:10:48 AM »
I've been away a while so, haven't followed up until this evening. I want to thank everyone for the help. First, it appears to me that I'm missing some things in my win.ini file. I'l take care of that and anything missing in system32 directory very shortly. I'll keep all informed. Thanks again ........
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: WsWin 2.0 ?e-mail
« Reply #9 on: April 18, 2003, 11:08:32 PM »
Please do.

Good luck - Mike
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #10 on: April 30, 2003, 05:07:37 AM »
Mike et all: I duplicated every statement Mike had in his win.ini file in mine. My Windows/system32 folder already had mapi32.dll and mapistub.dll in it. I added a mapi.dll file in the folder.

The results: I no longer get the "cannot locate mapi.dll file" message. However, it doesn't open Outlet Express or a blank WSWin file page either.  On my Windows 95 computer, when I'm in WSWin and click file send it will open a Windows Messaging window - which is how I use to use it. I'm wondering if the mapi.dll file that i put in the windows\system32 folder has anything to do with it since, I copied it out of Windows 98 not Windows 95. Mike, could you look at the mapi.dll version on your machine and let me know?   Thanks again for the help.

 
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

PGAGA

  • Advanced Member
  • *****
  • Posts: 118
  • I love YaBB 1G - SP1!
Re: WsWin 2.0  e-mail
« Reply #11 on: April 30, 2003, 06:24:41 AM »
Tuesday 29 April 2003

On my WinME system I have  different  MAPI.DLLs  backuped  up.  The one for OutLook (not Outlook Expresss) works.  The one withj Eudora does not--there is a different set of instructions.  The sample macro is designed for Outlook.

Phil
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #12 on: April 30, 2003, 09:52:22 AM »
Thank you, I'll keep trying ...........
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 266
  • Forum Administrator
    • WordStar Resource Site!
Re: WsWin 2.0 ?e-mail
« Reply #13 on: May 01, 2003, 03:57:15 AM »
Hi,

MAPI.DLL is version 5.51274.0 from Microsoft Exchange 5.5 and is described as "Extended MAPI 1.0 for Windows 3"!

mapi32.dll is version 1.0.2536.0 (XPClient.010817-1148) and part of Windows version 5.1.2600.0 and is described as "Extended MAPI 1.0 for Windows NT" - that's better.

mapistub.dll has the same details as mapi32.dll.

Hope this helps

Mike
« Last Edit: January 01, 1970, 04:00:04 AM by -1 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups

eeelmo

  • Member
  • **
  • Posts: 9
  • I love YaBB 1G - SP1!
Re: WsWin 2.0 ?e-mail
« Reply #14 on: May 07, 2003, 06:37:14 AM »
Thank you very much, you are very helpful - I'll keep you informed.    
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »