Author Topic: DOS wordstar with windows XP  (Read 9950 times)

rg

  • New Member
  • *
  • Posts: 1
DOS wordstar with windows XP
« on: January 31, 2004, 09:56:34 PM »
anyone know how to alter the cursor speed when using WS dos in XP?

In their `progress' Microsoft have removed the cursor speed adjustment secion from control panel.

Looking forward to some help
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

ostrowlaw

  • Full Member
  • ***
  • Posts: 43
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #1 on: July 25, 2004, 11:25:56 PM »
>:(

I just got around to installing Windows XP in my office.  We still use WS DOS 7.0 LAN, and have been using it successfully for many years.  We share your pain.  DOS programs can no longer be run using the windows scrren. only in the "full mode".  Fortunately, in full mode, the only thing lost is the cut and paste function, which can be toggled by going into windows mode (Alt-Right Enter).  If you find a solution, I'm all ears but I think we're are being "phased out"...

Alan
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Louie_Crew

  • New Member
  • *
  • Posts: 2
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #2 on: July 30, 2004, 07:07:55 PM »
Using Wordstar 7.0 for Dos in Windows XP I find that I
no longer have a status bar to tell me the line number
and column location of the cursor.  Is there a way that
I can regain access to that?  Through the
Windows Properties that I have specified for Wordstar?
Through wschange?

Nor will XP allow me to scroll down long directories
below the size of the Window when I am trying to choose a file to open from Wordstar's main menu.  Is there a way to fix that?

Also, as someone else indicated, I no longer have
access to the Ctrl-[ and Ctrl-] copy/paste functions.  When I try to use them, the program tells me that Windows must be running in the 'Enhanced mode."  How do I make that happen?  I would not want to if it cut off my access to all the other features of XP.

I have  been using Wordstar since 1983.  I would like to continue to do so.

Thanks in advance for any help.

Louie
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

ostrowlaw

  • Full Member
  • ***
  • Posts: 43
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #3 on: July 30, 2004, 10:35:47 PM »
First of all, did you try running WS in full screen mode, not in windows mode?  Click on Properties and under Display Options select full screen mode.  You can select the window size (try 80 x 28) and fonts (try Rastor Fonts 10 X 18).  These settings work for me.  I get the same screen in XP as under 98 or ME.

Enjoy.

Alan ;D
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

ostrowlaw

  • Full Member
  • ***
  • Posts: 43
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #4 on: July 30, 2004, 10:48:43 PM »
 
Nor will XP allow me to scroll down long directories  
below the size of the Window when I am trying to choose a file to open from Wordstar's main menu.  Is there a way to fix that?

If you change the screen from windows to full screen mode and adjust the size of the screen as I suggested, your directories will all be displayed.

Also, as someone else indicated, I no longer have  
access to the Ctrl-[ and Ctrl-] copy/paste functions.  When I try to use them, the program tells me that Windows must be running in the 'Enhanced mode."  How do I make that happen?  I would not want to if it cut off my access to all the other features of XP.

I have tried everything but to no avail.  I think the copy/paste window functions are now gone.  You'll have to save to a temp file and write it back.  There is another discussion about this on this page.

Let me know how you make out.
Alan
;D
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Louie_Crew

  • New Member
  • *
  • Posts: 2
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #5 on: July 31, 2004, 03:14:04 AM »
Thanks!

That did not work, but prompted me to try something else that did.  I ran wschange and reduced the heighth of my screen settings from 80 to 40 rows.  Now I can scroll through the Wordstar menus properly; I can see the row and column numbers in the bottom status bar.  And I can use XP edit function to copy and paste.

L.
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

ostrowlaw

  • Full Member
  • ***
  • Posts: 43
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #6 on: July 31, 2004, 03:30:37 AM »
Great.  Whatever works.

Alan
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

ostrowlaw

  • Full Member
  • ***
  • Posts: 43
  • I love YaBB 1G - SP1!
Re: DOS wordstar with windows XP
« Reply #7 on: January 02, 2005, 09:35:42 PM »
I've posted a "work around" to use the paste function in WS DOS.  However, it only works in Windows mode, not in full screeen mode (sigh!!!)

Alan
???
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »

Forum Admin

  • Administrator
  • Advanced Member
  • *****
  • Posts: 259
  • Forum Administrator
    • WordStar Resource Site!
« Last Edit: January 01, 1970, 04:00:00 AM by 1111651200 »
Forum Administrator
WordStar Resource Site

Join the WordStar mail list at Yahoo Groups